In order to use the YumaPro SDK's restconf program on an SELinux system there are several requirements:


  1. You must use YumaPro SDK version 17.10 (or later)
  2. You will need to set SELinux to permissive mode, consult your System Administrator for details
  3. You must run netconfd-pro with the –fileloc-fhs parameter set to true, which requires root permission:

        

user@system:~$ sudo netconfd-pro --fileloc-fhs=true


For more information please refer to the RESTCONF Installation Section 4 of the YumaPro SDK Installation Guide